DirectAdmin Php Versiyon Değiştirme / Seçme

DirectAdmin destekli hosting hizmetlerinde Php Versiyon Seçme yani php selector işlemi oldukça basittir. Bu makalede cliaweb üzerinden aldığınız directadmin hosting hizmetlerinde nasıl php versiyonlarını php 5.1 ila php 7.3 arasında seçebileceğinizi anlatacağız.

Bu makalede yer alan DirectAdmin Php Versiyon Değiştirme / Seçme işlemini tüm Linux Hosting ve Linux Reseller hizmetlerinde gerçekleştirebilirsiniz.

Öncelikle DirectAdmin panelimize giriş yaparak buradan Select PHP Version tıklıyoruz;

Php Sürümü Seçme İşlemi Aşağıdaki Gibidir. 1, 2 ve 3 aşamaları sırası ile uygulayınız;

 

Current PHP Version (işaretli olan) : Şu anki php versiyonu ifade eder. Örneğin bizde şu anki seçili php versiyon 5.6 imiş.

PHP Version : Seçilebilir php versiyonlarını ifade eder. Buradan farklı bir php versiyonu seçebilirsiniz.

Switch to PHP Options : PHP hata gösterme gibi özellikleri açıp kapatmanızı sağlar.

Reset Default: Tüm seçtiklerinizi varsayılan ayarına getirir, yani sıfırlar.

Modül Aktif Veya Deaktif Etme : Scriptiniz için gerekli olan bir modülü modüllerin isminin yazılı olduğu alanda kutucuklara tıklatıp aktif edebilir, veya tekrar tıklayıp deaktif edebilirsiniz.

 

PHP SELECTOR HAKKINDA İPUÇLARI;

1- PHP Selector de sağ üst kısımda Switch to Php Options göreceksiniz. Buraya tıkladığınızda harici php ayarları açılır. Örneğin display error açıp kapatabilirsiniz. Bu sayede ekrana basılacak olan hataları görebilir, çözebilir tekrar kapatabilirsiniz.

2- Örneğin hostunuzda çalıştıracağınız scriptin mysql sürücüsü farklı ise o sürücüye yönelik mysql modülü seçmelisiniz. Bu duruma göre cliaweb olarak sizlere bazı mantıksal seçenekler sunacağız. Aşağıdaki gibi kendi php scriptinize göre modüllerden seçimler yapabilirsiniz;

Php scriptinizin mysql sürücüsü mysql ise şu modüller seçilmelidir; mysqlnd ve nd_mysql
Php scriptinizin mysql sürücüsü mysqli ise şu modüller seçilmelidir; mysqlnd ve nd_mysqli
Php scriptinizin mysql sürücüsü pdo ise şu modüller seçilmelidir; mysqlnd ve nd_pdo_mysql

3- Php taraflı önbellekleme için opcache veya memcache modülü seçebilirsiniz. Eğer php de önbellekleme yapılmasın istiyor iseniz bu modüllerin seçimini kaldırınız ve Save ediniz.

Önerilen Diğer Konular